Kenny Kim
  • Male
  • Toronto
  • Canada
Share on Facebook Share on Facebook Share
  • Blog Posts
  • Discussions (518)
  • Groups
  • Photos
  • Photo Albums
  • Videos

Kenny Kim's Discussions

RE0,1,2??
10 Replies

Does anyone using PIC18 know if RE0, RE1, RE2 are actually implemented? It says they are implemented in the textbook but when i use those to take analog inputs the values seem to be floating...Continue

Started this discussion. Last reply by xiaoyang Mar 13, 2016.

RTC infinitely resetting to 00:00:80
7 Replies

has anyone had any trouble with the RTC infinitely resetting to 00:00:80? It's not just on startup, because my function to keep track of time based on the RTC is no longer working (and just was two…Continue

Started this discussion. Last reply by cas Jul 1, 2015.

Powering the board 12V problems
7 Replies

Quick question, for those of you who are using the 12 V adaptor to power up your devbugger, has any of you encountered the problem when sometimes you switch off the power and turn it back on the LCD…Continue

Started this discussion. Last reply by xiaoyang Mar 13, 2016.

Finding the operation time
18 Replies

kk serious question, no jokes.how do you find elapsed time? either with timers or RTC?thanks!!Continue

Started this discussion. Last reply by xiaoyang Mar 13, 2016.

Gifts Received

Gift

Kenny Kim has not received any gifts yet

Give a Gift

 

Kenny Kim's Page

Latest Activity

Kenny Kim replied to Kenny Kim's discussion RE0,1,2??
"t I had weird issues with using any of PORT E for input. It works fine for output, but sometimes thinks got funky when measuring input voltage"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RE0,1,2??
" i tried to measure it using the voltmeter and the voltage levels output by the photosensors are certainly able to be picked up by the port if the ports do work correctly. Thanks for your help though!  "
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RE0,1,2??
" Hmm yeah it's weird... For me AN1, AN9, and AN10 didn't work properly so I had to test others one by one to see which works and which don't. Also make sure it's not a soldering issue"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RE0,1,2??
"yea i did set that..but they still give me erroneous results. All the analog ports other than those three work perfectly fine and i have no clue why lol  "
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RE0,1,2??
" they do work, make sure you set the TRISE register"
May 1, 2014
Kenny Kim posted discussions
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RTC infinitely resetting to 00:00:80
" I reset the code for an hour, changed nothing, and it started working again. I'm gonna go kill myself now"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RTC infinitely resetting to 00:00:80
"My rtc broke - turned out to be a pic issue cause my a/d converter also broke at the same time. Try a new pic? Worked for me"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RTC infinitely resetting to 00:00:80
" try check if u used 0x73~78 in any other part of code"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RTC infinitely resetting to 00:00:80
" so far 99% of my problems with RTC have been a slightly loose jumper. literally just touch it and it starts to work again"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RTC infinitely resetting to 00:00:80
"we had an issue like that - we just took out the battery, put it back, and reprogrammed the board.  no idea why that worked"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion RTC infinitely resetting to 00:00:80
"I've also tried switching just about everything out and I have no idea what is going on"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion Powering the board 12V problems
"i used a two-pin connector that goes in the adaptor like this one http://www.ebay.com/bhp/12v-dc-connector    and just connect those two pins to 12V and ground"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion Powering the board 12V problems
"Yeah I've seen that issue.  Did you just lop off the adapter part and use the wires?"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion Finding the operation time
" 60 and add to seconds. That gives you the proper time difference in seconds, then you have to convert this binary difference back into BCD, which involves continually dividing by 10, so you need to write a subroutine for dividing by 10, which…"
May 1, 2014
Kenny Kim replied to Kenny Kim's discussion Finding the operation time
"If you want to do it with subtraction, it's quite a tedious process, i did it this way: you have to first convert the 2 BCD digit RTC gives you into proper binary numbers, which means you need a multiply the second digit by 10 and add to the…"
May 1, 2014

Comment Wall

You need to be a member of Personal Mechatronics Lab to add comments!

Join Personal Mechatronics Lab

  • No comments yet!
 
 
 

© 2017   Created by PML.   Powered by

Badges  |  Report an Issue  |  Terms of Service